[Researching] When starting RAT it resets the Max World Transfer Speed

thebjord

New Member
Everytime I want RAT to launch the server (if my PC restarts etc) and RAT is freshly opened, it has the max transfer speed set to 512, where the config says 1300 is the max, even when I set it to 1300. I have tried 1300 in serverconfig.xml and saved it, it overwrites it, I set it in RAT and click Save, it resets it still to 512, when setting serverconfig.xml to 1300 and making the file readonly, it cannot launch the server, even with RAT and/or 7daystodieserver.exe run as Admin, etc nothing I do seems to help, and I hate having a 16k world that takes AGES for my friends to download the world for the first time. Any way to fix this that someone knows without me manually having to change it before RAT launches the server?

-EDIT- Nevermind, digging I must have missed this my first times through, I found File > Settings > a checkbox labelled "Automatically update serverconfig.xml file when starting the server" and disabled that, not sure why it's enabled by default and forcing the 512kiB transfer speed, but since disabling that, even after PC reboot I see it stay at the 1300 I want, and RAT doesn't change it anymore.
Leaving this here as a bug report incase it's useful to anyone else experiencing the same problem or the author decides this isn't the desired default behavior.
 
Last edited:

Trekkan

JFF Administrator
Staff member
That is indeed a bug. And you worked around it, exactly as why that feature was created. Incase there is a bug, you can continue.

The reason RAT modifies the XML on startup, is that you can change whatever settings you want in RAT and then when you start your server, those changes take affect. By unchecking the box you did, any changes you make that would need to be applied to the serverconfig.xml, will not happen. So you're basically taking manual control of editing that file and leaving RAT out of it. Which, is completely ok, there aren't a lot of settings there that need to change much.
 

Kademlia

New Member
7D2D RAT Supporter
There are other settings that also reset when RATS is restarted. I have found the following items reset when RATS is relaunched/restarted (I only use the remote feature):

1. Under remote tab, the auto connect time is reset to 30 seconds.
2. Alloc's webmap IP and port under the teleport/misc tab (This may not be important on remote feature but I assume it's for local server use).

Other than that everything runs great and RATS is really lightweight. I even was able to get it running in Wine on a Linux virtual machine for use of the remote feature. Able to import DB from other computer and everything.
 
Top