Unable to backup

GamingSanctum

New Member
Hello!
I recently installed A19 and the latest 7d2dRAT. I've got the server up and running, but I'm having trouble getting the backups to work. When looking at screenshots and reading other threads, it looks like maybe I am missing a file location option on the server settings > Backup/Restore Tab?(See attached images)

I have not defined unique/unconventional user/save game directories and am using the defaults but RAT is reporting that it cannot find the game world. Anything glaringly wrong in my setup?
1198
11991200
 

Trekkan

JFF Administrator
Staff member
You're going to want to make sure the Game world and Save Game Name are set correctly on the Server Settings -> Game Settings 1 tab. RAT uses that information to determine your save game/world information for backups. Please let me know if that solves (or not) the issue for you. =)
 

GamingSanctum

New Member
Hmm it looks like the game name changed after the random generation. I had it set to RWG. It generated a map, but then placed it under the "East Tausa County" folder instead of the RWG folder. Is that normal or did my random gen not work properly?

edit: but thank you. That led me down the right path. The backups are working now that it's pointing to that gameworld
 

Trekkan

JFF Administrator
Staff member
Hmm it looks like the game name changed after the random generation. I had it set to RWG. It generated a map, but then placed it under the "East Tausa County" folder instead of the RWG folder. Is that normal or did my random gen not work properly?

edit: but thank you. That led me down the right path. The backups are working now that it's pointing to that gameworld
Yeah, that's exactly how it works. Once the game generates a world, they are placed under a "random" world named folder. So then you have to go back and switch it in RAT. This is new and I haven't figured out a good way to handle it, because you aren't going to be the only one getting hung up on that.

If you have any suggestions on what might have worked better for you (knowing that I can't determine the game world folder automatically), please let me know!
 

GamingSanctum

New Member
Yes, that's a weird way to handle it. I'm sure they have their reasons.....
That's a hard one for you to adjust for. I notice that the log reports which world it's using to generate:
2020-07-10T02:42:14 239.092 INF WorldGenerator:Generating West Wakahu Territory
Maybe there's some possibility of when the serverconfig is set to RWG - finding the pattern in the log files and auto-switching the game world after RWG takes place?

If nothing else, maybe just a quick blurb in the documentation mentioning this process. I read through a lot of documentation and previous threads looking for what I was doing wrong, lol.

Ultimately this is one of those things where I feel like 7d2d should have just left the world gen in the RWG folder (it even makes an RWG folder but places it under the world name afterwards).
 

Skauld

New Member
Hey,

I'm probably being really dense and for that; sorry! But I have the same problem but I'm not quite sure how you got it working.

After reading the thread, I checked and sure enough my game did the same thing, it created another folder called "Old Fimuzo Valley". Perhaps I misread or not quite understanding but what I got out of this thread was to rename 'RWG' with 'Old Fimuzo Valley' but in RAT, it's a dropdown menu and I can only select from the dropdown list.

So I figured perhaps it was the game name I had to edit instead but then that just created another folder inside "Old Fimuzo Valley" called the same name and essentially creates a new game.
And I figured that perhaps if I edit the serverconfig.xml manually to change RWG, RAT doesn't reflect this.

Any ideas what I'm missing?
 

Trekkan

JFF Administrator
Staff member
Hey,

I'm probably being really dense and for that; sorry! But I have the same problem but I'm not quite sure how you got it working.

After reading the thread, I checked and sure enough my game did the same thing, it created another folder called "Old Fimuzo Valley". Perhaps I misread or not quite understanding but what I got out of this thread was to rename 'RWG' with 'Old Fimuzo Valley' but in RAT, it's a dropdown menu and I can only select from the dropdown list.

So I figured perhaps it was the game name I had to edit instead but then that just created another folder inside "Old Fimuzo Valley" called the same name and essentially creates a new game.
And I figured that perhaps if I edit the serverconfig.xml manually to change RWG, RAT doesn't reflect this.

Any ideas what I'm missing?
This is more my fault than yours. ;)

In order to generate a new world:
  • Use RWG in the game world dropdown in RAT
  • Set a game name to anything you want.
  • Start your server.
  • After some time (usually 20-60 minutes), your game world will be generated.
  • Close RAT
  • Reopen RAT
  • Change the game world name from RWG to whatever it is that was auto generated by the game server (Such as "Old Fimuzo Valley"), and then change the game name to the game name you used before.
In short, I need to figure out a cleaner way for people to generate a new world, and I need to requery the game worlds to update the dropdown when you do (so you don't have to close/reopen RAT).

Hope that helps! If not, please let me know and I'll do what I can to get you going.
 

Skauld

New Member
Hey!

Thanks for your speedy reply and guide!

Following your steps, I get to the last part and that's where I'm stuck/confused. After I close down RAT and re-open it. I navigate to "Server Settings -> Game Settings 1" Where it says "Game World Name: RWG" is it here that I rename "RWG" to the autogenerated name (In my case "Old Fimuzo Valley")? Because I'm unable to type in the field whatsoever.

Sorry for being a pain, I appreciate you taking the time out to help though!

Just in case it's important.
I'm using version 0.2.06.1
 

Trekkan

JFF Administrator
Staff member
Hey!

Thanks for your speedy reply and guide!

Following your steps, I get to the last part and that's where I'm stuck/confused. After I close down RAT and re-open it. I navigate to "Server Settings -> Game Settings 1" Where it says "Game World Name: RWG" is it here that I rename "RWG" to the autogenerated name (In my case "Old Fimuzo Valley")? Because I'm unable to type in the field whatsoever.

Sorry for being a pain, I appreciate you taking the time out to help though!

Just in case it's important.
I'm using version 0.2.06.1
First, you're not being a pain at all. It wrote the software, I should support it as best I can (especially when people are dealing with bugs/bad design on my part). =)

Second, "Old Fimuzo Valley" should be in the dropdown already, you shouldn't have to type it in? If it isn't in the dropdown list... did you set a value for the "User Data Folder"? You shouldn't need to by default and if you did... there are some issues there that I'm still working out. If you can use the default (empty field), it should work as I've described.
 

Skauld

New Member
Well, I certainly appreciate it!

So you had guessed right. I did indeed set "User Data Folder", my bad! I removed it and it generated the world and it now appears in the dropdown list and now the backup works as intented.

You fixed it, thank you! I would of never figured it out.
=}
 

Trekkan

JFF Administrator
Staff member
Well, I certainly appreciate it!

So you had guessed right. I did indeed set "User Data Folder", my bad! I removed it and it generated the world and it now appears in the dropdown list and now the backup works as intented.

You fixed it, thank you! I would of never figured it out.
=}
Awesome, glad its working for you! I need to get that bug fixed. Hopefully this weekend. =)
 

imgood575

New Member
Trekkan, thank you! i did get my game to actually backup and not be a 1kb file, but im still getting ingame notice of backup failure, but when i look the backup is in my backup folder. Any help would be greatly appreciated.
 

Trekkan

JFF Administrator
Staff member
Trekkan, thank you! i did get my game to actually backup and not be a 1kb file, but im still getting ingame notice of backup failure, but when i look the backup is in my backup folder. Any help would be greatly appreciated.
I'll have to check the code and see what causes of failure there could be. You should have two backup files now, the game world and the save games. Make sure that you have both files and that both of them contain your content.

The only other thing I can think of offhand is storage space? Meaning you're not out, etc?
 

imgood575

New Member
im running ark servers and 7dtd on an actual dell 710 with 10 TB storage and 192GB ram, so storage isnt any problem. Its all good, just ingame while saving it says failed but when i check backup location i have my saves, so dont know, probably something ive got wrong. Thanks for the reply
 

Ciro

Member
JFF Member
7D2D RAT Supporter
Yes, that's a weird way to handle it. I'm sure they have their reasons.....
That's a hard one for you to adjust for. I notice that the log reports which world it's using to generate:

Maybe there's some possibility of when the serverconfig is set to RWG - finding the pattern in the log files and auto-switching the game world after RWG takes place?

If nothing else, maybe just a quick blurb in the documentation mentioning this process. I read through a lot of documentation and previous threads looking for what I was doing wrong, lol.

Ultimately this is one of those things where I feel like 7d2d should have just left the world gen in the RWG folder (it even makes an RWG folder but places it under the world name afterwards).
that is what i had thought myself when i went back through the doc, sooo wrote something up for how i tell people to do it when asked and BadPlayer ramade the doc to add the extras. unsure when it will get uploaded to the site tho so sorry about that missed part it was my bad when going through it.
 

Ciro

Member
JFF Member
7D2D RAT Supporter
im running ark servers and 7dtd on an actual dell 710 with 10 TB storage and 192GB ram, so storage isnt any problem. Its all good, just ingame while saving it says failed but when i check backup location i have my saves, so dont know, probably something ive got wrong. Thanks for the reply
hmm have you checked both zips and the size of them?
 

kimila

New Member
This is more my fault than yours. ;)

In order to generate a new world:
  • Use RWG in the game world dropdown in RAT
  • Set a game name to anything you want.
  • Start your server.
  • After some time (usually 20-60 minutes), your game world will be generated.
  • Close RAT
  • Reopen RAT
  • Change the game world name from RWG to whatever it is that was auto generated by the game server (Such as "Old Fimuzo Valley"), and then change the game name to the game name you used before.
In short, I need to figure out a cleaner way for people to generate a new world, and I need to requery the game worlds to update the dropdown when you do (so you don't have to close/reopen RAT).

Hope that helps! If not, please let me know and I'll do what I can to get you going.
Have make a bug on this too.
But found out now, Thanks.
Just ignore my bug post.
 
Top