So... we see you haven't signed up here on our website.  

Do you really want to sit here and be "Unregistered" all your life?  No, of course you don't!  So, click this here link and you'll take that all important first step into enlightenment! (or something, whatever...)

!Claim not working

Discussion in 'General' started by Lobodemonio, Jan 26, 2019.

  1. Lobodemonio

    Lobodemonio New Member

    Points:
    41
    For some reason !Claim had stopped working. I got a new API key ect but it still isn't working. It is registering the votes but not giving the rewards. I have checked that there is a bag assigned to it ect. Can anyone help please? :)
     
  2. Trekkan

    Trekkan JFF Administrator Staff Member

    Points:
    1,359
    What do you see in the console/RAT Logs when someone types the command?
     
  3. Lobodemonio

    Lobodemonio New Member

    Points:
    41
    2019-01-27 09:12:58 11207.144 INF (BCM) Global:Lobodemonio:171: !claim
    2019-01-27 09:12:58 11207.145 INF Chat (from '76561198062521165', entity id '171', to 'Global'): 'Lobodemonio': !claim
     
  4. Lobodemonio

    Lobodemonio New Member

    Points:
    41
    I have also noticed that in the Grab Bag section I am unable to select consumables such as food or splints into the bags, they are highlighted in red. This is new as I did had consumables in the bags before.
     
    Last edited: Jan 27, 2019
  5. Trekkan

    Trekkan JFF Administrator Staff Member

    Points:
    1,359
    Ahh ok, I think I see what's happening. In RAT, click File -> Import Items / Blocks -- Then wait for the popup to appear saying its done (5ish seconds).

    This will get a list of all possible items/blocks so RAT knows what IDs are associated with them. Basically, when the game updates, there are times that this information will change internally to the game. RAT needs to know this about that. Once you do that, the items in RED might go away (or appear as different items, but probably not), if not, remove them and re-add them as their IDs have changed.

    This might also explain why your !claim isn't working, is because internally, there are no matching items to give the player. So basically do what I said, then check all of your bags for invalid (red) items, and readd them.
     
  6. Lobodemonio

    Lobodemonio New Member

    Points:
    41
    Brilliant! I'll let you know how it goes.
     
  7. Lobodemonio

    Lobodemonio New Member

    Points:
    41
    Hi Trekkan. Unfortunately it still isn't working. So it registers the first !claim but it doesn't allocate the items. The reason I know it registers the first is because if your try a second time you get the massage that says you've already claimed.
     
  8. Trekkan

    Trekkan JFF Administrator Staff Member

    Points:
    1,359
    In the console tab in RAT, change the dropdown to "RAT Logs" and see if there are any issues when someone typed the !claim there.
     
  9. Lobodemonio

    Lobodemonio New Member

    Points:
    41
    2019-01-28 18:36:11 ----------------------------------
    Current Time: 28/01/2019 18:36:11
    Thrown by: Void ThrowKeyNotFoundException()
    Method: eventScript.LogException
    Message: The given key was not present in the dictionary.
    Stack Trace:
    at System.ThrowHelper.ThrowKeyNotFoundException()
    at System.Collections.Generic.Dictionary`2.get_Item(TKey key)
    at RAT.grabbag.GetBagItems(Int32 BagID, String PlayerName)
    at RAT.grabbag.DeliverGrabBag(_player playerInfo, Int32 bagId)
    at RAT._servervoting.ClaimVote(Dictionary`2 DataObject)
    at RAT.RATCommand.ServerVoteClaim(String RawParams, Dictionary`2 DataObject)
    at RAT.eventScript.ProcessEventScript(_event ev, Dictionary`2 DataObject, String ScriptToProcess)
    ----------------------------------


    That was the log for a claim.
     
  10. Trekkan

    Trekkan JFF Administrator Staff Member

    Points:
    1,359
    Sounds like you have a bag with items in it that do not exist. Did you delete all of the RED items from before?

    No idea how extensive you have bags setup. But worst case, delete the bags (which delete all items in them), and then start over. Sorry, no idea offhand how else to fix it or what would cause it (other than red items still in there).
     
  11. Lobodemonio

    Lobodemonio New Member

    Points:
    41
    OK I'll give that a go. Cheers for the help again
     

Share This Page