[Completed] Backups only backing up my data

Ian Lee

New Member
It appears that the RAT backups are only backing up my player data and not all the players on the server. Is this expected? I hope not. Unfortunately, I just discovered this after a player's data got corrupted and I needed to restore them. The restore function in RAT didn't fix him so I investigated and found this. Fortunately, I had a different backup. However, it wasn't as recent as the RAT backup would have been. Do I have something setup wrong or do backups not actually backup the entire game?

Thanks!
Ian
 

Trekkan

JFF Administrator
Staff member
It appears that the RAT backups are only backing up my player data and not all the players on the server. Is this expected? I hope not. Unfortunately, I just discovered this after a player's data got corrupted and I needed to restore them. The restore function in RAT didn't fix him so I investigated and found this. Fortunately, I had a different backup. However, it wasn't as recent as the RAT backup would have been. Do I have something setup wrong or do backups not actually backup the entire game?

Thanks!
Ian
There is no selective backup for RAT. Meaning, it backs up your savegame folder, which includes the player folder and all player files in it. Can you give me some specifics as to what you expected and what RAT did, and what your other backup had done the way you expected? I haven't heard of this issue before.

Basically, also please paste the paths of your save games, etc.
 

Ian Lee

New Member
In this screenshot you can see that in my 7D2D saves folder (Explorer on the right) that there are many player files. However, inside the backup .zip file that RAT created (Explorer on the bottom left) that there is only one player's data included. That player happens to be me. Something similar is happening in the Region backups. In the Saves directory there exist 698 .7rg files. However, the backup only contains 4 files. I don't know enough about these files to be able to know how they align.

The other backup I've setup is just the Windows Backup utility to backup the entire game directory on a daily basis.
 

Attachments

Trekkan

JFF Administrator
Staff member
Ok, I think I know what might be happening, please send me a screenshot of the Server Configuration tab.
 

Trekkan

JFF Administrator
Staff member
If you open your serverconfig.xml file, did you change the following property?

<!--property name="SaveGameFolder" value="absolute path" /--> <!-- use this to override the default save game path -->

If you did, RAT doesn't know about that setting currently.

You can also set the backup source specifically in RAT instead of letting RAT figure it out. In your first screenshot, Uncheck the "Use Default Location", then under that, set the location of where your save game files are. RAT will back up everything in and under that folder. Let me know how that goes please. =)
 

Ian Lee

New Member
That seems to have worked. I removed the path from the config and configured it through RAT as you instructed. Now my backups are 1.7 GB instead of the 3.9 MB that they were before... Wow.

Thanks!
Ian
 

Trekkan

JFF Administrator
Staff member
That seems to have worked. I removed the path from the config and configured it through RAT as you instructed. Now my backups are 1.7 GB instead of the 3.9 MB that they were before... Wow.

Thanks!
Ian
Sure thing, I need to add in support for that parameter from the config and things will be back to normal without you having to set it.
 

Ian Lee

New Member
BIG PROBLEM. Apparently, I didn't do a full restart after testing that yesterday. Just did a restart after testing the fix for shutting down and discovered a big problem with this fix. When you remove the path from the config, the game saves a new game to the default users/appdata folder instead of the RAT configured save folder which starts a new game. I had to restore the path in config file in order to get the game back. Please fix this ASAP. I think I'm going to have to go back to the stable build. Too many issues in this one.
 

Trekkan

JFF Administrator
Staff member
BIG PROBLEM. Apparently, I didn't do a full restart after testing that yesterday. Just did a restart after testing the fix for shutting down and discovered a big problem with this fix. When you remove the path from the config, the game saves a new game to the default users/appdata folder instead of the RAT configured save folder which starts a new game. I had to restore the path in config file in order to get the game back. Please fix this ASAP. I think I'm going to have to go back to the stable build. Too many issues in this one.
Ok, that makes sense. I'll get it fixed. =)
 

Trekkan

JFF Administrator
Staff member
BIG PROBLEM. Apparently, I didn't do a full restart after testing that yesterday. Just did a restart after testing the fix for shutting down and discovered a big problem with this fix. When you remove the path from the config, the game saves a new game to the default users/appdata folder instead of the RAT configured save folder which starts a new game. I had to restore the path in config file in order to get the game back. Please fix this ASAP. I think I'm going to have to go back to the stable build. Too many issues in this one.
Also, this issue won't be any different in another version of RAT, as that bug has to of been there for some time. I think most people use the default save game folder and it wasn't noticed.
 

Ian Lee

New Member
It seems to be working if I uncheck the default location box and supply the save path in both the config file and in RAT. Who knows, it may start a new game next time I restart but for now it appears to be running the correct game and creating proper backups.
 
Top